2ちゃんねる ★スマホ版★ ■掲示板に戻る■ 全部 1- 最新50  

■ このスレッドは過去ログ倉庫に格納されています

サポート打ち切るのが早い言語、Ruby、Perl、etc

1 :デフォルトの名無しさん:2012/11/09(金) 01:33:44.21
リリースしてから10年はサポートしろよ。
アマチュアの仕事じゃねーんだからさ。

2 :デフォルトの名無しさん:2012/11/09(金) 01:40:41.28
このスレッドは天才チンパンジー「アイちゃん」が
言語訓練のために立てたものです。

アイと研究員とのやり取りに利用するスレッドなので、
関係者以外は書きこまないで下さい。

                  京都大学霊長類研究所

3 :デフォルトの名無しさん:2012/11/09(金) 02:10:54.61
もう打ち切られたのか??????????????????

4 :デフォルトの名無しさん:2012/11/09(金) 02:25:24.43
人間の数世代分サポートすれば、人間同士のギャップが発生しなくていいわな
例えば3世代分とか

5 :デフォルトの名無しさん:2012/11/09(金) 02:42:36.11
http://www.ruby-lang.org/ja/news/2011/10/07/plans-for-1-8-7/

> 思います。 2008年にリリースされた1.8.7版のRubyは、当時としては最先端の大変

> 2013年6月より先は、1.8.7はあらゆるサポート対象外になります。

たったの5年か(笑)

6 :デフォルトの名無しさん:2012/11/09(金) 04:56:17.95
2008年にリリースされた1.8.7版は当時としてもクズであり、詐欺寸前のJavaからの移行などを
謳い文句に多数の方を阿鼻叫喚の地獄へ叩き落しました。心より情弱乙と申し上げます。
当然、今後も使う奴は真性のバカであります。開発者は1.8に完全に飽きました。
これからは1.9使うよな当然。

7 :デフォルトの名無しさん:2012/11/10(土) 03:39:37.04
安定が欲しい人はFORTRAN使ってればいいの?

8 :デフォルトの名無しさん:2012/11/10(土) 04:10:08.66
Cがいい

9 :デフォルトの名無しさん:2012/11/10(土) 11:35:05.38
Cにサポートかいう概念はないからな

10 :デフォルトの名無しさん:2012/11/10(土) 12:23:09.91
MSのステマですか?

Visual Basic 6 が今でも成功している理由
ttp://msdn.microsoft.com/ja-jp/magazine/jj133828.aspx

最初に Visual Basic 6 がリリースされたのは 1998 年なので、
Visual Basic 6 アプリケーションは少なくとも 24 年にわたって
サポートされることになります

11 :デフォルトの名無しさん:2012/11/10(土) 13:16:07.83
>>10
VB6のことを知っていれば
10年サポートじゃなくて
20年サポートって言ってますよw

12 :デフォルトの名無しさん:2012/11/10(土) 13:37:31.90
ここでいうサポートという概念がよく分からない
MSは2003ぐらいには既にVisual StudioではVB6もレガシーASPも使えなくなったろ

ってことはVB6は実質的には5年でサポート打ち切りじゃね

13 :デフォルトの名無しさん:2012/11/10(土) 19:34:44.67
PS3で出来ないからPS2はサポート切れって論法か

14 :デフォルトの名無しさん:2012/11/10(土) 19:59:11.83
>>1
オープンソースソフトの作者は
これでメシ食ってるわけじゃないんで
アマチュアだと思うよ?
彼らをプロとして扱いたいのなら
契約を結んでしっかり金を払うことだ。

15 :デフォルトの名無しさん:2012/11/10(土) 21:36:03.80
Ruby 1.9.3-p327 がリリースされました

16 :デフォルトの名無しさん:2012/11/10(土) 21:51:22.58
VBは今でも業務アプリで新規案件結構ある。
Perlは後方互換性高くて10年前のプログラムでも余裕で最新の5.16で動く。
Rubyは本当、互換性クソ。
3年前に数千万円かけて作ったRailsアプリは今じゃ資産価値ゼロ。まるごと作り直した方がましだから。

17 :デフォルトの名無しさん:2012/11/11(日) 01:11:49.32
>>16
Ruby1.8とかで動かせばいいだけじゃないの?

18 :デフォルトの名無しさん:2012/11/11(日) 12:24:33.30
>>16
動くかどうかではなくサポート終了の話

http://news.mynavi.jp/news/2011/05/17/060/index.html
> なおPerl 5.14のリリースにともない、Perl 5.10のサポートは終了となっている。

19 :デフォルトの名無しさん:2012/11/11(日) 13:05:25.14
言語のサポートって何してくれるのさ

20 :デフォルトの名無しさん:2012/11/11(日) 13:49:03.77
>>19
Rubyの例でいえばこんなこと

http://www.ruby-lang.org/ja/news/2011/10/07/plans-for-1-8-7/
> 2012年6月まで、通常のメンテナンスが続きます。
> それ以降、バグフィックスリリースは終了いたします。2013年6月までは
> セキュリティフィックスは続けますので、それまでは1.8.7をお使いいただけます。
> 2013年6月より先は、1.8.7はあらゆるサポート対象外になります。

具体的にはこんなことの対応
http://www.ruby-lang.org/ja/security/
> 既知のセキュリティ問題
>
> ruby 1.9 におけるハッシュ飽和攻撃による DoS 脆弱性 (CVE-2012-5371) 2012年11月10日公開
> 不当な NUL 文字挿入によって意図しないファイルが生成されうる脆弱性の対応 2012年10月12日公開
> Exception#to_s 等による $SAFE 機構をバイパス可能な脆弱性の対応 (CVE-2012-4464, CVE-2012-4466) 2012年10月12日公開
> Security Fix for RubyGems: SSL server verification failure for remote repository 2012年4月20日公開
> Security Fix for Ruby OpenSSL module: Allow 0/n splitting as a prevention for the TLS BEAST attack 2012年2月16日公開
> Exceptionのメソッドの$SAFE機構をバイパス可能な脆弱性について 2011年2月18日公開

バグの対応(サポート)
https://bugs.ruby-lang.org/projects/ruby-193/issues?set_filter=1&status_id=5

21 :デフォルトの名無しさん:2012/11/11(日) 18:31:23.01
Ruby1.8だとRailsとか新しいライブラリは動かないよね。
Perl5.8出た当時ってRuby1.6だよね。Ruby1.6で書かれたプログラムをメンテしてくれって言われて、一体どうすればいいんだろうか。
PerlとかPHPは10年前のプログラムが普通に動いてるよ。

22 :デフォルトの名無しさん:2012/11/11(日) 18:33:09.69
VB6だってWin3.1だって、今でも使われてるところじゃ使われてる。
LAN内とかオフラインで使えばセキュリティもへったくれもないからね。

23 :デフォルトの名無しさん:2012/11/11(日) 18:44:55.37
Rubyの互換性の酷さはRuby本体だけじゃなくて、Railsもでしょう。
ちょっとバージョンが上がったらこのプラグインは動かないとか、このDBじゃ動かないとか。

24 :デフォルトの名無しさん:2012/11/11(日) 18:52:31.09
>>22
> LAN内とかオフラインで使えば

RubyとPerlはインターネット上の
ウェブアプリには使うなってことかw

25 :デフォルトの名無しさん:2012/11/11(日) 19:27:35.77
Perlは、使えるね

26 :デフォルトの名無しさん:2012/11/11(日) 23:18:05.56
4ー5年前に流行ったRails1.0のサイトは今はもう全滅してるだろうな。

27 :デフォルトの名無しさん:2012/11/18(日) 02:30:07.88
Perlは仕事に使うために作られた。
Rubyは作ってみたくて作った。
だから使いやすいかどうかやメンテされる期間はおのずと決まってくる。

イノベーションとサポート打ち切りを混同するモダンパーラーには違和感
を覚える。

28 :デフォルトの名無しさん:2012/11/18(日) 03:37:05.23
>>20
ありがとう勉強になった

29 :デフォルトの名無しさん:2012/11/18(日) 06:02:43.91
サポート長い方がいいっていうのもあるけど、昔作ったプログラムが最新の処理系で動くのなら、そんなに困らない。
その点、RubyやRailsはバージョンアップ時に互換性を大きく失って行くので、過去のプログラムは大幅な書き換えを余儀なくされる。
Perlは後方互換性が非常に高く、昔作ったプログラムが現行の処理系でもほとんど手直しなしに動く。

30 :デフォルトの名無しさん:2012/11/18(日) 09:46:29.53
それはスクリプト言語の弱点かもね。
実行時にコードを解釈していくから
どうしても開発時とは違った環境で動かすことになる。

Perlも互換性はかなり悪いよ。
コアライブラリだけを使っていればいいけど
cpanモジュールとか最悪。
使わなければ、開発効率悪いし。

31 :デフォルトの名無しさん:2012/11/18(日) 11:39:09.04
長期的に保守する必要があるならCPANモジュールを使うなってことだろう。
モジュールの作者がどっち方向に行こうとしているのかあるいは飽きっぽくて
投げ出しちゃうタイプなのかで仕事に使うプログラムが左右されるのは困る。

32 :デフォルトの名無しさん:2012/11/18(日) 13:15:22.45
職業プログラマならCPANモジュールはuseするんじゃなくて、その中身を
自分のスクリプトの中に書き写しておけ、ということになる

33 :デフォルトの名無しさん:2012/11/18(日) 13:33:39.45
ローカルに置いとけばいいじゃん

34 :デフォルトの名無しさん:2012/11/18(日) 16:09:10.48
自分の手元でソースを管理できるならそれもあり。
数年ごとに人事異動があって、しかも忘れたころに戻ってくるようなとこなら
自衛的に埋め込んでおくのが正解。

35 :停止しました。。。:停止
真・スレッドストッパー。。。( ̄ー ̄)ニヤリッ

9 KB
■ このスレッドは過去ログ倉庫に格納されています

★スマホ版★ 掲示板に戻る 全部 前100 次100 最新50

read.cgi ver 05.02.02 2014/06/23 Mango Mangüé ★
FOX ★ DSO(Dynamic Shared Object)